Dead MCA PLUS

Identifiy and fix common problems with Ford electronics.
Post Reply
User avatar
Stevebe
Active member
Posts: 224
Joined: 08 Feb 2019, 12:28

Dead MCA PLUS

Post by Stevebe » 07 Jan 2020, 17:22

I have just got a NOS MCA PLUS and it’s as dead as a do do.
So far with 13volt feed it draws 290 To 300Ma there it stays on /off makes no difference also heating mem made no difference
There are no led, screen or any thing happening, no signs of any damage anywhere so next step make a few test readings
And also try to establish if it’s the main board or the graphics board, I think sub with working to find where the fault lies
A few pics
DB835695-E6A6-4715-A9B7-646A53D08B14.jpeg
4B87108F-8DA4-4E7D-8164-2A451C9328D1.jpeg
73B58989-C2A0-4E8F-9DE3-D118B63594CF.jpeg
Will update as I progress
You do not have the required permissions to view the files attached to this post.
Digimod

DGAlexandru
Active member
Posts: 168
Joined: 04 Aug 2019, 22:47

Re: Dead MCA PLUS

Post by DGAlexandru » 07 Jan 2020, 19:31

If you have another FaceLift NX.. even wihout camera, you can swap the screens in order to see where is the problem - screen board or main one.

User avatar
Stevebe
Active member
Posts: 224
Joined: 08 Feb 2019, 12:28

Re: Dead MCA PLUS

Post by Stevebe » 07 Jan 2020, 19:45

Hi
Yes that will be the next thing I’ll be trying, I do have several units I wasn’t certain weather Nx boards would be compatible so thanks for the info

It’s the graphic board that’s causing the problem. Without a schematic can only check the obvious.. no Biggy.. use this one for bits,
Digimod

Go4IT
Pro
Posts: 557
Joined: 08 Feb 2019, 12:25

Re: Dead MCA PLUS

Post by Go4IT » 08 Jan 2020, 16:19

No, NX graphicsboards are not applicable on MCA mainboards. They are completely different in hardware (Cyclone III instead of Cyclone II, etc.) and connectors. They won't even fit.

You need to use always same unit familiy (FX, NX or MCA) to swap components.

You should also try if you can JTAG to the device in order to repair an aborted update, that may also caused this issue.

User avatar
Stevebe
Active member
Posts: 224
Joined: 08 Feb 2019, 12:28

Re: Dead MCA PLUS

Post by Stevebe » 08 Jan 2020, 17:59

I did realize they were different. The NX all the voltages are good as far as I can tell but this was Andys old board it decided to lock me out totally
After I tried to erase the sdram, if you remember had a bad section that would not erase entirely...
then I could not connect any more..
The MCA The test voltages are all at zero until I unplug the graphics board. Guess I need to take a look
Digimod

Go4IT
Pro
Posts: 557
Joined: 08 Feb 2019, 12:25

Re: Dead MCA PLUS

Post by Go4IT » 16 Mar 2020, 10:49

Hey Stevebe, any progress on you dead MCA? (indeed from the photos it is a MCA2-Plus, equiped with the extra center-speaker amp).
The system shuts down power if there are issues. My first bet would be to reflash the mainboard. If it's ok, it runs even without an graphicsboard connected.

User avatar
Stevebe
Active member
Posts: 224
Joined: 08 Feb 2019, 12:28

Re: Dead MCA PLUS

Post by Stevebe » 16 Mar 2020, 14:31

I have since picked up another one fully working I’ll have to get back into it a see where the problems lay
Digimod

User avatar
Stevebe
Active member
Posts: 224
Joined: 08 Feb 2019, 12:28

Re: Dead MCA PLUS

Post by Stevebe » 17 Mar 2020, 23:13

Go4IT wrote:
16 Mar 2020, 10:49
Hey Stevebe, any progress on you dead MCA? (indeed from the photos it is a MCA2-Plus, equiped with the extra center-speaker amp).
The system shuts down power if there are issues. My first bet would be to reflash the mainboard. If it's ok, it runs even without an graphicsboard connected.
What is the difference in hardware with MCA2 I can’t see any difference with other one I have
Digimod

Post Reply