S-max 2019 cluster dead

IPC - Instrument cluster panels (like Convers+)
Post Reply
amplified
Active member
Posts: 79
Joined: 09 Feb 2020, 14:19

S-max 2019 cluster dead

Post by amplified »

Hi all!

I got one s-max cluster to play around. After connecting it to UCDS, there was something strange - vbf loader didn't want to insert SBL, but under update wizard (S-max 2015>) it found all files(same) and started programming, all good but after finish - nothing. Dash just blinks the illumination for few seconds (after ign on) and then stops to send CAN msgs and goes dark. I tried update wizard, vbf loader, dead module... nothing -> it sees the dash, goes to load SBL and fails. When i poll the module first second after ign on it sees some info, after 5 seconds it sees nothing.
on first poll screenshot -> 1st try is after few seconds, then the second with some info is right after i reset everything and send ign on again.
smax-1.png

then when just woken up it shows some info and dtc-s....
smax-2.png

before i tried updating it it was working but sometimes maybe crashes like this - just illumination blinking, resets on its own after a period of time. reset by software wasn't helping.

Failed to load SBL! Error: Conditions Not Correct [0x22]
You do not have the required permissions to view the files attached to this post.
Last edited by amplified on 18 May 2021, 09:07, edited 1 time in total.
amplified
Active member
Posts: 79
Joined: 09 Feb 2020, 14:19

Re: S-max 2019 cluster dead

Post by amplified »

E5F7F067-B712-436D-B8BE-EA9711AF4157.jpeg
smax-3.png
smax-4.png
You do not have the required permissions to view the files attached to this post.
amplified
Active member
Posts: 79
Joined: 09 Feb 2020, 14:19

Re: S-max 2019 cluster dead

Post by amplified »

Any ideas? Dash is same as mondeo mk5...
User avatar
Stevebe
Pro
Posts: 256
Joined: 08 Feb 2019, 12:28

Re: S-max 2019 cluster dead

Post by Stevebe »

What can message are you sending to ipc for ignition on
Also just check the can connections allso add a 120 ohm resistor across can buss,,
The other thing inside on right near sound there is 3 test points rx tx g connect uart then use putty terminal see im the MB86R03
350C4129-5D21-4964-A2CD-36A10C220747.jpeg
IPC UART MONITOR WILS UCDS UPDATE.txt
You do not have the required permissions to view the files attached to this post.
Digimod
amplified
Active member
Posts: 79
Joined: 09 Feb 2020, 14:19

Re: S-max 2019 cluster dead

Post by amplified »

Don't understand what exactly you mean. Cluster shows DTC and shows some info about files, but as seen in picture - 3 of files are not there.
phx-
Starter
Posts: 30
Joined: 17 Dec 2019, 20:39

Re: S-max 2019 cluster dead

Post by phx- »

maybe it helps, firstly upload all calibration files,after that unplug ipc from battery (just disconect), for 2 mins cca but ucds let it still run, then plug back ipc and upload just sbl and ECU calibration file, unplug it again..may it works... few times and did that and it revive dead ipc from mondeo mk5 (2017)
fingers crossed
never give up !
amplified
Active member
Posts: 79
Joined: 09 Feb 2020, 14:19

Re: S-max 2019 cluster dead

Post by amplified »

I can't upload anything it says "SBL LOAD FAIL" ;)
User avatar
Stevebe
Pro
Posts: 256
Joined: 08 Feb 2019, 12:28

Re: S-max 2019 cluster dead

Post by Stevebe »

amplified wrote: 08 Jun 2021, 16:54 I can't upload anything it says "SBL LOAD FAIL" ;)
HAVE YOU GOT A IGNITION CAN on hs3
you must send ignition on all time other wize UCDS wont work here are to try both send from UCDS
although i think there is a bug in thr latest version in the can bus player

on hs3 id 3b3 data 40800012FF040000
or this data 4048000F00050002
Digimod
Post Reply